Decreased performance of the BitBar functionalities.
Incident Report for Bitbar Testing Cloud
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 13:36 UTC
Investigating
We're experiencing slowness that affects several BitBar functionalities.
The issue is being investigated.
Posted Jun 23, 2023 - 12:27 UTC
This incident affected: Cloud UI and API Access.