MacOS desktop browser unavailability in the EU region

Incident Report for Bitbar Testing Cloud

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 13:41 UTC

Investigating

We are currently investigating this issue.
Posted Apr 22, 2025 - 15:43 UTC