Degraded performance in the US West region

Incident Report for Bitbar Testing Cloud

Resolved

This incident has been resolved.
Posted Jan 02, 2025 - 09:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 02, 2025 - 09:08 UTC

Identified

We're experiencing a degraded performance of the data center in the US West region.
Posted Dec 24, 2024 - 11:05 UTC
This incident affected: Mobile Hub (Appium Broker) - By Region (Appium Broker US WEST).