Decreased availability of Windows browsers.

Incident Report for Bitbar Testing Cloud

Resolved

This incident has been resolved.
Posted Jun 16, 2023 - 12:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 14, 2023 - 13:18 UTC